summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-03 18:11:13 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-03 19:12:57 -0500
commit70971c4a53f8dbc01518986171b72044d187cb39 (patch)
tree4beb326effc9fa3e6c78378abc656b8b9a1182f8 /dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild
parentsys-fs/android-file-transfer-linux: Stabilize 4.1 amd64, #763324 (diff)
downloadgentoo-70971c4a53f8dbc01518986171b72044d187cb39.tar.gz
gentoo-70971c4a53f8dbc01518986171b72044d187cb39.tar.bz2
gentoo-70971c4a53f8dbc01518986171b72044d187cb39.zip
dev-python/paho-mqtt: Version bump to 1.5.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild')
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild
new file mode 100644
index 000000000000..ba6f3e2ee05f
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for MQTT v5.0, v3.1.1, and v3.1"
+HOMEPAGE="https://www.eclipse.org/paho/index.php?page=clients/python https://github.com/eclipse/paho.mqtt.python"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-strip-test-dependency.patch"
+)