summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-05 20:54:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-05 21:45:30 +0200
commitd165401be34eeb6cc53707dc137a79a273008f3a (patch)
tree35832f601e4579a12edea3b83cf536650bdfe369 /dev-python/parso
parentdev-python/ipyparallel: Bump to 8.8.0 (diff)
downloadgentoo-d165401be34eeb6cc53707dc137a79a273008f3a.tar.gz
gentoo-d165401be34eeb6cc53707dc137a79a273008f3a.tar.bz2
gentoo-d165401be34eeb6cc53707dc137a79a273008f3a.zip
dev-python/parso: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.8.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index c9700b84340d..793c61e38836 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1 +1,2 @@
DIST parso-0.8.3.gh.tar.gz 397648 BLAKE2B 8942408e27198075c92ef51f7a191cc7781eb3a5110119b91fd95f86e13ebe2fbfee11022a2bfec794150f60b3af8c4d5f324cb011703cd581c17f92232ae5bf SHA512 7874460053662d40c2cfcf0015e330e1c8201eeb07682e2079a636db553a82dc25b70b14ad0f0c82fb817f655359d695101a17f616abf9a39f49c61ae5fd49b1
+DIST parso-0.8.4.gh.tar.gz 398241 BLAKE2B 5a8a81f64b20b52cd3349b7bc059621733debfaf5cc271f3e89423d63e4af67391f7740c34b450b2a91fafe34b8986926e8f7c4ca0b8600eafd0171c01e664b0 SHA512 da96f0ab6cfbcf2a54ee73262a672bb4d9720aa91fd884a8c17165d597eece97569b7ee87fd7ea1c0be663c0cb2930a66a03b4e305070f59f346485817607db3
diff --git a/dev-python/parso/parso-0.8.4.ebuild b/dev-python/parso/parso-0.8.4.ebuild
new file mode 100644
index 000000000000..8418e5c05160
--- /dev/null
+++ b/dev-python/parso/parso-0.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="
+ https://github.com/davidhalter/parso/
+ https://pypi.org/project/parso/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+ # With python3.11 this additional file is run by pytest,
+ # but it is not actually a test and thus fails
+ parso/python/token.py::parso.python.token.PythonTokenTypes
+)