summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-09 00:36:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-09 00:36:11 +0200
commit5fdb82d7778d0f922f254e46ecc54b11790fcd69 (patch)
tree15ccae2fa0ce6c3808d6287a6eb212fe394bb5d6 /dev-python/partd
parentdev-python/google-auth: Bump to 1.28.1 (diff)
downloadgentoo-5fdb82d7778d0f922f254e46ecc54b11790fcd69.tar.gz
gentoo-5fdb82d7778d0f922f254e46ecc54b11790fcd69.tar.bz2
gentoo-5fdb82d7778d0f922f254e46ecc54b11790fcd69.zip
dev-python/partd: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/partd')
-rw-r--r--dev-python/partd/Manifest1
-rw-r--r--dev-python/partd/partd-1.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/partd/Manifest b/dev-python/partd/Manifest
index 56cb9e14bd4a..9add878940fa 100644
--- a/dev-python/partd/Manifest
+++ b/dev-python/partd/Manifest
@@ -1 +1,2 @@
DIST partd-1.1.0.tar.gz 35497 BLAKE2B fb9461daccd5f3215471b201bd30be1fdd499f929490b1819899c7396d1d541fa46c629c26bcef5567df259ef0de1ec8effc3b7b498dec0235a4c0117a1c6014 SHA512 5e26c4a63fc2f9a290b211c1fce291da6b3354b4d0fdf941d29ddad1252629c94275ac360d33c88d11ff4e36a4f4d6bee42edd867c92eb7ef0d2697472c9a338
+DIST partd-1.2.0.tar.gz 36720 BLAKE2B dccc14704134d1453b92e896080a820b817efc78f86511307d4d1f6e2787f38935edaa8fdfb0ea4f2350ab99f5ad06cef98bb1eba4d4e45b2582a3ada2f5d907 SHA512 dbcf6a73e23aacd6502f0669abcb8e51547f280b1b7b94baa7ab5637cd838f8427ad1c4e39127fb7f8b164f3a83b66611b2c71667d31fe0137619fb6c457fab9
diff --git a/dev-python/partd/partd-1.2.0.ebuild b/dev-python/partd/partd-1.2.0.ebuild
new file mode 100644
index 000000000000..91a5db4fd7ca
--- /dev/null
+++ b/dev-python/partd/partd-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Appendable key-value storage"
+HOMEPAGE="https://github.com/dask/partd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/locket[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blosc[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest