summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-25 00:06:33 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-25 00:06:33 -0800
commit86afcdf9222f5f3f32398c12777aba22f192054b (patch)
tree981f97bef88501fe814466ed345e2a66d61c2bb4 /dev-python/path-py/path-py-11.5.2.ebuild
parentdev-python/jaraco-packaging-6.2-r1: fix setuptools_scm removal (diff)
downloadgentoo-86afcdf9222f5f3f32398c12777aba22f192054b.tar.gz
gentoo-86afcdf9222f5f3f32398c12777aba22f192054b.tar.bz2
gentoo-86afcdf9222f5f3f32398c12777aba22f192054b.zip
dev-python/path-py: fix setuptools_scm removal
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/path-py/path-py-11.5.2.ebuild')
-rw-r--r--dev-python/path-py/path-py-11.5.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/path-py/path-py-11.5.2.ebuild b/dev-python/path-py/path-py-11.5.2.ebuild
index 5955abedeba6..2f33ff1c53da 100644
--- a/dev-python/path-py/path-py-11.5.2.ebuild
+++ b/dev-python/path-py/path-py-11.5.2.ebuild
@@ -35,7 +35,10 @@ S="${WORKDIR}/${MY_P}"
distutils_enable_tests pytest
python_prepare_all() {
- sed -i "s:use_scm_version=True:version='${PV}',name='path.py':" setup.py || die
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
+ setup.cfg || die
# disable flake8 tests
sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \