summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 06:41:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 06:41:55 +0100
commit4d395837444fb8441135efb9dfb9bd19f087cb59 (patch)
tree90677cf6da484f7f9532aef8cf5bcb15d302e18e /dev-python/pathspec/pathspec-0.10.3.ebuild
parentapp-admin/awscli: Bump to 1.27.27 (diff)
downloadgentoo-4d395837444fb8441135efb9dfb9bd19f087cb59.tar.gz
gentoo-4d395837444fb8441135efb9dfb9bd19f087cb59.tar.bz2
gentoo-4d395837444fb8441135efb9dfb9bd19f087cb59.zip
dev-python/pathspec: Bump to 0.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pathspec/pathspec-0.10.3.ebuild')
-rw-r--r--dev-python/pathspec/pathspec-0.10.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pathspec/pathspec-0.10.3.ebuild b/dev-python/pathspec/pathspec-0.10.3.ebuild
new file mode 100644
index 000000000000..a69ad1fd06dd
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.10.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths"
+HOMEPAGE="
+ https://github.com/cpburnz/python-pathspec/
+ https://pypi.org/project/pathspec/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests unittest