summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-20 10:52:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-20 10:52:53 +0200
commit03cf2359e92e25d020e34e20f9ea959abb1a830d (patch)
tree2330adc1bd84721e0ed08a2534fff66c8c4a9dda /dev-python/pdm-backend
parentdev-python/makefun: Remove old (diff)
downloadgentoo-03cf2359e92e25d020e34e20f9ea959abb1a830d.tar.gz
gentoo-03cf2359e92e25d020e34e20f9ea959abb1a830d.tar.bz2
gentoo-03cf2359e92e25d020e34e20f9ea959abb1a830d.zip
dev-python/pdm-backend: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdm-backend')
-rw-r--r--dev-python/pdm-backend/Manifest1
-rw-r--r--dev-python/pdm-backend/pdm-backend-2.3.1.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/pdm-backend/Manifest b/dev-python/pdm-backend/Manifest
index a88fa7271b3f..85c9ebe87320 100644
--- a/dev-python/pdm-backend/Manifest
+++ b/dev-python/pdm-backend/Manifest
@@ -1,3 +1,2 @@
-DIST pdm-backend-2.3.1.gh.tar.gz 136710 BLAKE2B 72293989700a429bfddb1d865b14f0467d56e024d69976264909d1c5113be67fd6892f3821803b6e86d73653f54a62b15ccb02f3dc16a190f6ccd0ca5e0650b5 SHA512 6a1a4d45a95b08f0a06f54635224c6faabc000384f489eb1e462d7dfffdd9899a3040a0fb708d193b3da541e2704b30921185728a178517fa55ecf3314f9903d
DIST pdm-backend-2.3.2.gh.tar.gz 136819 BLAKE2B 15f1375a646337f25fa37b94cd88d257849dbaa79cc2153ca608c4bc35d8e243f7d2a63ddcac87d435bea2fa5200b2d254544720d959566584526c8f182f9152 SHA512 acbf3be68dba894152b0257dbb99ba21e120e5dd48c5989fe5047a6c0073c58f829cb52f8537f32b096838202f0a29f2c38cab43d5c284d1b610811c9f2c25a3
DIST pdm-backend-2.3.3.gh.tar.gz 136942 BLAKE2B 14f2584f22f1c4e08f687c77621269ae1e5acfe4babb1ab427c10d65ff07841b8175479f867870b9a5745db76444ca140a7da497a94c831ca6d0ea1e67b4e88f SHA512 382ad95e2811f1142fee66065f96ede1a646c3e2b9fbfafc6afb17442d3aeccfbf1ff6260952986a025791d3d56a2c4b730decb3cb65e893c25a710e16cbcfc8
diff --git a/dev-python/pdm-backend/pdm-backend-2.3.1.ebuild b/dev-python/pdm-backend/pdm-backend-2.3.1.ebuild
deleted file mode 100644
index cdd2b6fbda8a..000000000000
--- a/dev-python/pdm-backend/pdm-backend-2.3.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
-HOMEPAGE="
- https://pypi.org/project/pdm-backend/
- https://github.com/pdm-project/pdm-backend/
-"
-SRC_URI="
- https://github.com/pdm-project/pdm-backend/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-# see src/pdm/backend/_vendor/vendor.txt
-RDEPEND="
- >=dev-python/editables-0.5[${PYTHON_USEDEP}]
- >=dev-python/packaging-24.0[${PYTHON_USEDEP}]
- >=dev-python/pyproject-metadata-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
-
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-# setuptools are used to build C extensions
-RDEPEND+="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- rm -r src/pdm/backend/_vendor || die
- find -name '*.py' -exec sed \
- -e 's:from pdm\.backend\._vendor\.:from :' \
- -e 's:from pdm\.backend\._vendor ::' \
- -e 's:import pdm\.backend\._vendor\.:import :' \
- -i {} + || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- # this must not be set during src_test()
- local -x PDM_BUILD_SCM_VERSION=${PV}
- distutils-r1_src_compile
-}
-
-src_test() {
- git config --global user.email "test@example.com" || die
- git config --global user.name "Test User" || die
- distutils-r1_src_test
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -k "not [hg"
-}