summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 03:29:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 03:34:51 -0500
commit0fe82c13471ec4ab44d877acc5750aea7f1cb527 (patch)
tree50087256cfd4ad9e333cdd682f032e2047ff477e /dev-python/pecan/pecan-1.0.3.ebuild
parentdev-python/logutils: had amd64 listed twice, fixing (diff)
downloadgentoo-0fe82c13471ec4ab44d877acc5750aea7f1cb527.tar.gz
gentoo-0fe82c13471ec4ab44d877acc5750aea7f1cb527.tar.bz2
gentoo-0fe82c13471ec4ab44d877acc5750aea7f1cb527.zip
dev-python/pecan: adding for openstack liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/pecan/pecan-1.0.3.ebuild')
-rw-r--r--dev-python/pecan/pecan-1.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pecan/pecan-1.0.3.ebuild b/dev-python/pecan/pecan-1.0.3.ebuild
new file mode 100644
index 000000000000..c679d7f1f7a3
--- /dev/null
+++ b/dev-python/pecan/pecan-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, designed to be lean and fast, with few dependencies."
+HOMEPAGE="https://pypi.python.org/pypi/pecan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"