summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-30 13:50:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-30 14:46:21 -0500
commitd8a692822bedc360d53d7fb00ea116dcdfd3a17a (patch)
tree99f4d2858feb0c0a28da19fecdcfcc0b2960ad5f /dev-python/pecan/pecan-1.2.1.ebuild
parentmedia-sound/clementine: Replaced fdo-mime with xdg-utils eclass. (diff)
downloadgentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.tar.gz
gentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.tar.bz2
gentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.zip
dev-python/pecan: 1.2.1 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/pecan/pecan-1.2.1.ebuild')
-rw-r--r--dev-python/pecan/pecan-1.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pecan/pecan-1.2.1.ebuild b/dev-python/pecan/pecan-1.2.1.ebuild
new file mode 100644
index 000000000000..3021c4cc8f28
--- /dev/null
+++ b/dev-python/pecan/pecan-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.python.org/pypi/pecan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/simplejson-2.1.1[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"