summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-27 22:51:03 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-27 22:51:20 -0600
commit99e8fc7599a9bc7d7b1219f627a84bb922df6676 (patch)
tree7c3b0305f50a7dc15d483f514e34c453c0c04156 /dev-python/pexpect
parentmedia-libs/mesa: Install VA-API files inside ${EPREFIX} (diff)
downloadgentoo-99e8fc7599a9bc7d7b1219f627a84bb922df6676.tar.gz
gentoo-99e8fc7599a9bc7d7b1219f627a84bb922df6676.tar.bz2
gentoo-99e8fc7599a9bc7d7b1219f627a84bb922df6676.zip
dev-python/pexpect: 4.6.0 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest1
-rw-r--r--dev-python/pexpect/pexpect-4.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index f4c41a9c88ca..b55e25ad3519 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1 +1,2 @@
DIST pexpect-4.2.1.tar.gz 143980 BLAKE2B b5cb9c7847eabdf8778bddc6b208520edb9b3611d7a981fae6e371fa6deafebe142ba8361e3a1d21187cd692576c91d732f3def75e19989296f50b2a9fb4d4c6 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261
+DIST pexpect-4.6.0.tar.gz 148966 BLAKE2B 0ed1a3c31133bf618e4c75ea099efaa9bda9e2b7f92f46c54ad553ecc56487e5415b750334376a95599ada53e17e91efe7d4b65ad80bb4f6a1cf9d655a3c9685 SHA512 9a2b1ef19d885e69cfd17ba0519581f782574019010043e66d8b68f98ac86b359f4a1ca42f8bb0059a5dfdd43275ad93531c076cc0ac2049e109408961b46bbd
diff --git a/dev-python/pexpect/pexpect-4.6.0.ebuild b/dev-python/pexpect/pexpect-4.6.0.ebuild
new file mode 100644
index 000000000000..02f1b078ff97
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
+HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}