summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-27 16:09:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-27 18:24:11 -0600
commitc640d10af286865cd9712bc61226275ef0dae5c6 (patch)
treea30f13ad7c61524e38c3841550b5824a52caac63 /dev-python/pexpect
parentdev-python/ptyprocess: add py37 support (diff)
downloadgentoo-c640d10af286865cd9712bc61226275ef0dae5c6.tar.gz
gentoo-c640d10af286865cd9712bc61226275ef0dae5c6.tar.bz2
gentoo-c640d10af286865cd9712bc61226275ef0dae5c6.zip
dev-python/pexpect: add py37 support
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/pexpect-4.2.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pexpect/pexpect-4.2.1.ebuild b/dev-python/pexpect/pexpect-4.2.1.ebuild
index 4ec6aea19456..f42f3bd52ca8 100644
--- a/dev-python/pexpect/pexpect-4.2.1.ebuild
+++ b/dev-python/pexpect/pexpect-4.2.1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"