summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2018-01-24 20:27:19 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-01 09:43:15 +0100
commit795ff79d5f37f40e31a138c440985f68d640ff35 (patch)
tree49719671e84dc86e3b593829c42bc127a0db72aa /dev-python/pipenv/pipenv-9.0.0-r1.ebuild
parentmedia-sound/rhythmbox: fix unittests due to uninstalled schemas (diff)
downloadgentoo-795ff79d5f37f40e31a138c440985f68d640ff35.tar.gz
gentoo-795ff79d5f37f40e31a138c440985f68d640ff35.tar.bz2
gentoo-795ff79d5f37f40e31a138c440985f68d640ff35.zip
dev-python/pipenv: fix outdated dependency version
Bug: https://bugs.gentoo.org/645530 Closes: https://github.com/gentoo/gentoo/pull/6951 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/pipenv/pipenv-9.0.0-r1.ebuild')
-rw-r--r--dev-python/pipenv/pipenv-9.0.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pipenv/pipenv-9.0.0-r1.ebuild b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..2d9715d9d7a4
--- /dev/null
+++ b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.python.org/pypi/pipenv"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
+ >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
+ >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# not completely packed
+# requires networking
+RESTRICT="test"
+
+python_test() {
+ py.test -v -v || die
+}