summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-07 20:49:43 +0100
committerSam James <sam@gentoo.org>2023-09-07 20:50:32 +0100
commit49415cdf5ba3be16c3e329bef3016ef2e8a8ae46 (patch)
treea3bf55d017b1ef2fcfb355279ca2ac0c381a6abd /dev-python/pkgcraft
parentsys-cluster/kube-scheduler: drop 1.27.3 (diff)
downloadgentoo-49415cdf5ba3be16c3e329bef3016ef2e8a8ae46.tar.gz
gentoo-49415cdf5ba3be16c3e329bef3016ef2e8a8ae46.tar.bz2
gentoo-49415cdf5ba3be16c3e329bef3016ef2e8a8ae46.zip
dev-python/pkgcraft: fix live dep
It needs to be something more than 9999 because of how DEPEND is currently written. Fixes: 60d0dad4ebaf447e98a13c9b96889fdc3f43bf4d Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.6.ebuild2
-rw-r--r--dev-python/pkgcraft/pkgcraft-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild
index 96f8ad5480d3..204a8185dbfb 100644
--- a/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild
+++ b/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
inherit git-r3
- PKGCRAFT_VERSION_MAX="9999"
+ PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
PKGCRAFT_VERSION_MIN="9999"
else
SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
diff --git a/dev-python/pkgcraft/pkgcraft-9999.ebuild b/dev-python/pkgcraft/pkgcraft-9999.ebuild
index 96f8ad5480d3..204a8185dbfb 100644
--- a/dev-python/pkgcraft/pkgcraft-9999.ebuild
+++ b/dev-python/pkgcraft/pkgcraft-9999.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
inherit git-r3
- PKGCRAFT_VERSION_MAX="9999"
+ PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
PKGCRAFT_VERSION_MIN="9999"
else
SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"