summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-05 20:25:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-05 20:25:33 +0300
commit540c6ae09aeee9fa0b4c0853140498aaef59be36 (patch)
tree42d6fc16bd6e1b217e6cad1974779ce9a388d2eb /dev-python/prettytable
parentsys-kernel/rt-sources: bump 4.19.237_p107 (diff)
downloadgentoo-540c6ae09aeee9fa0b4c0853140498aaef59be36.tar.gz
gentoo-540c6ae09aeee9fa0b4c0853140498aaef59be36.tar.bz2
gentoo-540c6ae09aeee9fa0b4c0853140498aaef59be36.zip
dev-python/prettytable: add 3.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 254f7d231533..db76e50cb998 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1 +1,2 @@
DIST prettytable-3.2.0.tar.gz 52976 BLAKE2B ec41ffe9c752f530128d641a3341cc5c2dc4fd26ae8cf795fd526144ae8c82d359d022a9d52aebcea3217251c7d9513ef2df0f50c3a4f31ec0c2ef6b9c7e6189 SHA512 8f2a0945159727741a52ffdaa5602b862841cb8e0c33d3f755699f4376d2c0bfa539a270e56242503f94cb4fc469cbfd27348abfd740ec8f1cd3f1970053e5db
+DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
diff --git a/dev-python/prettytable/prettytable-3.3.0.ebuild b/dev-python/prettytable/prettytable-3.3.0.ebuild
new file mode 100644
index 000000000000..e5850a816952
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest