summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-12 13:11:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-12 13:37:39 +0200
commitf79ee9f8a5168c11e0b02245db93be4247aa7f08 (patch)
treea0357953f4da1eab22e4620b42c8473767e0b15a /dev-python/prettytable
parentdev-python/openapi-spec-validator: Bump to 0.5.7 (diff)
downloadgentoo-f79ee9f8a5168c11e0b02245db93be4247aa7f08.tar.gz
gentoo-f79ee9f8a5168c11e0b02245db93be4247aa7f08.tar.bz2
gentoo-f79ee9f8a5168c11e0b02245db93be4247aa7f08.zip
dev-python/prettytable: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 650e3f44abf8..264935b2789c 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
DIST prettytable-3.7.0.tar.gz 47169 BLAKE2B cc749c6a42ad45359ccb6195378526d7c6da1be932770090cdcee565606131eaa1f83a01732781e3cf39719b4cb42824865b4855e5432e7517cbead139361e2d SHA512 4fe83cfc7f3fa4031191e0c9b4a70eb550c189a0921d3f85d1be5b8fce8c917034f8039861577a447b6705c4bbe49f6b18698605ffdef80e2f9bc81dafabeefe
+DIST prettytable-3.8.0.tar.gz 47735 BLAKE2B df31c77eaa4c0b4e7dc5845255383c13d5eff23c7fb8743c4cdd9f726229c84d98a0b4e66e8d42ec4d3e2d43db703d55706705d2e79c4ae8682b7b8b794217a4 SHA512 4719f16e98d4e7b89d8a7f6b2e1d15fd2c44410e5c9edc29a4dbb8ef2899eccff524932afe179bea7a6bbe607a809274b805e76e9ef2e3bf2c77f054635f8f04
diff --git a/dev-python/prettytable/prettytable-3.8.0.ebuild b/dev-python/prettytable/prettytable-3.8.0.ebuild
new file mode 100644
index 000000000000..e7e226037a5e
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest