summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-05-30 19:07:20 +0200
committerDavid Seifert <soap@gentoo.org>2019-05-30 19:07:20 +0200
commit181c5f62ce81f845f77c29c7fda438971338487e (patch)
tree7314783f732440eb1752481ff5c33da38d6132d1 /dev-python/progressbar/progressbar-2.5.ebuild
parentdev-python/graph-tool: Upper bound on boost (diff)
downloadgentoo-181c5f62ce81f845f77c29c7fda438971338487e.tar.gz
gentoo-181c5f62ce81f845f77c29c7fda438971338487e.tar.bz2
gentoo-181c5f62ce81f845f77c29c7fda438971338487e.zip
dev-python/progressbar: Bump to version 2.5
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/progressbar/progressbar-2.5.ebuild')
-rw-r--r--dev-python/progressbar/progressbar-2.5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/progressbar/progressbar-2.5.ebuild b/dev-python/progressbar/progressbar-2.5.ebuild
new file mode 100644
index 000000000000..1aa5f92eea07
--- /dev/null
+++ b/dev-python/progressbar/progressbar-2.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Text progressbar library for python"
+HOMEPAGE="https://pypi.org/project/progressbar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}"