summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer <tomboy64@sina.cn>2016-06-03 19:51:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-23 15:25:29 +0000
commit9bdeb0e7b787a98be60d0c57361557679a2a4fbf (patch)
tree24a4ceb41d1f771bf6af127291560b078a60c167 /dev-python/protobuf-python
parentdev-java/protobuf-java: version bump 3.0.0_beta3 (diff)
downloadgentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.tar.gz
gentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.tar.bz2
gentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.zip
dev-python/protobuf-python: version bump 3.0.0_beta3
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1603 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest2
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch (renamed from dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch)0
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch33
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.0.0_beta3.ebuild (renamed from dev-python/protobuf-python/protobuf-python-3.0.0_beta2.ebuild)4
4 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index ba9743b769c0..2e9b0964e70b 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1 +1 @@
-DIST protobuf-3.0.0_beta2.tar.gz 3333054 SHA256 be224d07ce87f12e362cff3df02851107bf92a4e4604349b1d7a4b1f0c3bfd86 SHA512 3a9329603226dabeaae7c28eb7463fb4403383e7774d53742e9e38a0426f5ef370803c68e4d4bc0d37585618fb340befe4f812731db0984b12032c3d931cdca7 WHIRLPOOL 0e77105c24d71c0269f4375ebfaef38175d762e1a90cdd81f594c13bbece9f390ada9291f722e8e0227952a1f5cd94976037f069b86703c7a3a37a9277cb66f8
+DIST protobuf-3.0.0_beta3.tar.gz 3654440 SHA256 d8d11564ff4085e7095cf5601fdc094946e6dbb0085863829668eb3a50b1ae0d SHA512 b8e0e73ab03d18b6715d875aff8552a603d46feaa5b7b4fb225ba841ff917381bdecf5083202ec1753fd1e82a8d0281937fba6d0f0928261a68c035f509360fd WHIRLPOOL dbc8896a0b1bb92a5e0a586c6952c7b32b2c0cfce03ed5c2f39634d038977f50fbc3b2e9297944316f73d258d21b6766a4fae8f86b65e096f92ed93b0bf1615e
diff --git a/dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch
index 3d419ba3d194..3d419ba3d194 100644
--- a/dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch
+++ b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch
diff --git a/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
new file mode 100644
index 000000000000..cb4a5f6cf7eb
--- /dev/null
+++ b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
@@ -0,0 +1,33 @@
+diff -Naur python/setup.py python/setup.py
+--- python/setup.py 2015-12-30 22:21:46.000000000 +0100
++++ python/setup.py 2016-04-18 00:51:49.490809789 +0200
+@@ -190,15 +190,27 @@
+ extra_compile_args.append('-Werror')
+ sys.argv.remove(warnings_as_errors)
+
++ inclD = ['.', '../src']
++ libD = []
++ try:
++ subprocess.check_call(['pkg-config', '--exists', 'protobuf'])
++ inclD += subprocess.check_output(['pkg-config','--variable=includedir','protobuf']).split()
++ libD = subprocess.check_output(['pkg-config','--variable=libdir','protobuf']).split()
++ except OSError as osex:
++ if osex.errno == errno.ENOENT:
++ info('pkg-config not found')
++ else:
++ warn("Running pkg-config failed - %s." % osex)
++ libD = ['../src/.libs']
+ # C++ implementation extension
+ ext_module_list.extend([
+ Extension(
+ "google.protobuf.pyext._message",
+ glob.glob('google/protobuf/pyext/*.cc'),
+- include_dirs=[".", "../src"],
++ include_dirs=inclD,
+ libraries=libraries,
+ extra_objects=extra_objects,
+- library_dirs=['../src/.libs'],
++ library_dirs=libD,
+ extra_compile_args=extra_compile_args,
+ ),
+ Extension(
diff --git a/dev-python/protobuf-python/protobuf-python-3.0.0_beta2.ebuild b/dev-python/protobuf-python/protobuf-python-3.0.0_beta3.ebuild
index 05552d0615ae..6e1efb28cfe9 100644
--- a/dev-python/protobuf-python/protobuf-python-3.0.0_beta2.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-3.0.0_beta3.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
inherit distutils-r1
-MY_PV=${PV/_beta2/-beta-2}
+MY_PV=${PV/_beta/-beta-}
DESCRIPTION="Google's Protocol Buffers - official Python bindings"
HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
dev-python/six[${PYTHON_USEDEP}]"
S="${WORKDIR}/protobuf-${MY_PV}/python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-PATCHES=( "${FILESDIR}/protobuf-${PV}-link-against-installed-lib.patch" )
+PATCHES=( "${FILESDIR}/${P}-link-against-installed-lib.patch" )
python_test() {
distutils_install_for_testing