summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-13 20:40:27 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-13 20:42:14 +0100
commit98d8947750b75da2960aa6a2f22aeb9d846ff85b (patch)
tree94a44083992b13a37b7589632ec4bd4f261ee91a /dev-python/pyblake2/pyblake2-1.0.0.ebuild
parentdev-python/libvirt-python: Stable on amd64 (diff)
downloadgentoo-98d8947750b75da2960aa6a2f22aeb9d846ff85b.tar.gz
gentoo-98d8947750b75da2960aa6a2f22aeb9d846ff85b.tar.bz2
gentoo-98d8947750b75da2960aa6a2f22aeb9d846ff85b.zip
dev-python/pyblake2: Bump to 1.0.0
Diffstat (limited to 'dev-python/pyblake2/pyblake2-1.0.0.ebuild')
-rw-r--r--dev-python/pyblake2/pyblake2-1.0.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pyblake2/pyblake2-1.0.0.ebuild b/dev-python/pyblake2/pyblake2-1.0.0.ebuild
new file mode 100644
index 000000000000..5f00679e0a58
--- /dev/null
+++ b/dev-python/pyblake2/pyblake2-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+# pyblake2 itself allows more licenses but blake2 allows the following three
+LICENSE="|| ( CC0-1.0 openssl Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+blake2_impl() {
+ local code='
+#if defined(__XOP__)
+ HAVE_XOP
+#elif defined(__AVX__)
+ HAVE_AVX
+#elif defined(__SSSE3__)
+ HAVE_SSSE3
+#elif defined(__SSE2__)
+ HAVE_SSE2
+#endif
+'
+ local res=$($(tc-getCC) -E -P ${CFLAGS} - <<<"${code}")
+
+ case ${res} in
+ *HAVE_XOP*) echo XOP;;
+ # this does not actually do anything but implicitly enabled SSE4.1...
+ *HAVE_AVX*) echo AVX;;
+ *HAVE_SSSE3*) echo SSSE3;;
+ # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
+ #*HAVE_SSE2*) echo SSE2;;
+ *) echo REGS;;
+ esac
+}
+
+python_prepare_all() {
+ # uncomment the implementation of choice
+ sed -i -e "/BLAKE2_COMPRESS_$(blake2_impl)/s:^#::" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}