summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 18:55:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 21:26:52 +0200
commit7cae49e6e65a023b37b111e0d16f662f3208abaa (patch)
tree2875d16b503186724a5ccafe64c7f0a4f6b30d27 /dev-python/pycairo/pycairo-1.19.1.ebuild
parentapp-emulation/containers-storage: Bump to version 1.20.2 (diff)
downloadgentoo-7cae49e6e65a023b37b111e0d16f662f3208abaa.tar.gz
gentoo-7cae49e6e65a023b37b111e0d16f662f3208abaa.tar.bz2
gentoo-7cae49e6e65a023b37b111e0d16f662f3208abaa.zip
dev-python/pycairo: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycairo/pycairo-1.19.1.ebuild')
-rw-r--r--dev-python/pycairo/pycairo-1.19.1.ebuild22
1 files changed, 4 insertions, 18 deletions
diff --git a/dev-python/pycairo/pycairo-1.19.1.ebuild b/dev-python/pycairo/pycairo-1.19.1.ebuild
index 66921d842bbe..01000a3ce9a2 100644
--- a/dev-python/pycairo/pycairo-1.19.1.ebuild
+++ b/dev-python/pycairo/pycairo-1.19.1.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -15,10 +15,9 @@ SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
+IUSE="examples"
BDEPEND="
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,29 +28,16 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-RESTRICT="!test? ( test )"
-
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
distutils_enable_tests setup.py
-python_check_deps() {
- use doc || return 0
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs -b html _build/html || die
- fi
-}
-
python_install() {
distutils-r1_python_install \
install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
}
python_install_all() {
- use doc && local HTML_DOCS=( _build/html/. )
-
if use examples; then
dodoc -r examples
fi