summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-14 10:26:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-14 10:28:30 +0100
commit8f53bbdf5e7b8d4e71fa13c5e8b8b31372b42c11 (patch)
tree8e757e4aa5e7268983d234df7e87760e284f5feb /dev-python/pydevd
parentdev-python/pychromecast: Remove old (diff)
downloadgentoo-8f53bbdf5e7b8d4e71fa13c5e8b8b31372b42c11.tar.gz
gentoo-8f53bbdf5e7b8d4e71fa13c5e8b8b31372b42c11.tar.bz2
gentoo-8f53bbdf5e7b8d4e71fa13c5e8b8b31372b42c11.zip
dev-python/pydevd: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest1
-rw-r--r--dev-python/pydevd/pydevd-2.6.0.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index df1e21f75e54..e354506cf14d 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,2 +1 @@
-DIST pydev_debugger_2_6_0.tar.gz 4142790 BLAKE2B 46776e261e77a745867423488f97c6584c9497d883d8e2b19f4f82c58472f410f1b5f287ce24b8c20e9cdaa2202cbc78235ea4a7e9aa2981aa520e0b58e4fcd3 SHA512 5e7703f2eec53fe7b4d78d59894cfbb14a35a62ad20431242477f66e72344d88d5538ebe2007526e4ff250e8bcf41702acc71692239693dd9cb788ced70d7aaa
DIST pydev_debugger_2_7_0.tar.gz 4154343 BLAKE2B 6504ffa5eee5548a6aa9e59712b6c0054b69c2e0f6ff48059ed8b2e3edb92ec92ea4e7f9ff084419b46310c4d08f11008571cbf70ccc4efddd0fae688e4110f5 SHA512 8f09b446eeaace1f9ecd3d331813e8bd7d8e09e1fe9dc9fa955ecc26a97ac6015f7becc4005a87405d1154280ec10eb7fa87914bcd41f27e51d90ad3eb99f643
diff --git a/dev-python/pydevd/pydevd-2.6.0.ebuild b/dev-python/pydevd/pydevd-2.6.0.ebuild
deleted file mode 100644
index 2682f0672a48..000000000000
--- a/dev-python/pydevd/pydevd-2.6.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-MY_P="pydev_debugger_${PV//./_}"
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
-S="${WORKDIR}/PyDev.Debugger-${MY_P}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-# After removing and recompiling the prebuilt lib the tests fail?
-# For some reason the test suite is executing a slightly different gdb command
-# then before, which is lacking the file name of the lib that was pre built:
-# gdb: No symbol table is loaded. Use the "file" command
-# This also happens outside of portage so it is not related to any *FLAGS
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/untangle[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# Block against the version of debugpy that still bundles pydevd
-RDEPEND="
- !<dev-python/debugpy-1.4.2
- sys-devel/gdb
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Drop -O3 and -flto compiler args
- sed -i \
- -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
- -e '/extra_compile_args/d' \
- setup.py || die
-
- # Clean up some prebuilt files
- rm -r third_party || die
- cd pydevd_attach_to_process || die
-
- # Remove these Windows files
- rm attach_{amd64,x86}.dll || die
- rm inject_dll_{amd64,x86}.exe || die
- rm run_code_on_dllmain_{amd64,x86}.dll || die
- rm -r windows winappdbg || die
-
- # Remove these MacOS files
- rm attach_x86_64.dylib || die
-
- # Remove these prebuilt linux files
- rm attach_linux_{amd64,x86}.so || die
-
- cd linux_and_mac || die
- rm compile_mac.sh || die
-}
-
-src_compile() {
- pushd pydevd_attach_to_process/linux_and_mac || die
- # recompile removed file (extracted from compile_linux.sh)
- $(tc-getBUILD_CXX) ${CXXFLAGS} ${CFLAGS} -o "attach_linux_${ARCH}.so" \
- -ldl ${LDFLAGS} -nostartfiles attach.cpp || die
- mv "attach_linux_${ARCH}.so" ../ || die
- popd || die
- python_foreach_impl distutils-r1_python_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process" || die
-}