summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 07:14:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 07:14:34 +0200
commitaf5e61b853f89fc1a0d75c6f5a20efb7fa6cb203 (patch)
treea59ddd70ce17fc946de3abad7c6022558578e472 /dev-python/pyghmi
parentdev-python/pyghmi: Remove old (diff)
downloadgentoo-af5e61b853f89fc1a0d75c6f5a20efb7fa6cb203.tar.gz
gentoo-af5e61b853f89fc1a0d75c6f5a20efb7fa6cb203.tar.bz2
gentoo-af5e61b853f89fc1a0d75c6f5a20efb7fa6cb203.zip
dev-python/pyghmi: Bump to 1.5.70
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.70.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 9262b353cf2e..52f491d02dff 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.69.tar.gz 257074 BLAKE2B af1b93bda37aa078c4a04f68970f86a2f6b7c005ed762977d8297bdb4ff8e89c972ec24342ccb226a6cb43d6085f89f23e4e8547e1632275accea0fc5f5558ff SHA512 ad6837b61748ff045196109050fc743e0335b9037e06c723be86e12c42569f6e46b2c004148b4ce4416d0e67967bf6b7596bc10bca30323e2eca11da54067f21
+DIST pyghmi-1.5.70.tar.gz 257192 BLAKE2B cf1ed047bf40e6ed81d322c091141b8012d7550afeba06fb5bed313ce37e2c5d79674a2d9deb1ade741488342d5e3d89ab3b65dfeb15e46aca52ebc3ca5b4dcc SHA512 61d6488034778a51e7a3ed34dadf758a98ed9670f079f6b90b4266191abd48aae5646e497b8ea9616eb1bce03f358b0017c7da1daea61e8be97d42bb1bfe1f18
diff --git a/dev-python/pyghmi/pyghmi-1.5.70.ebuild b/dev-python/pyghmi/pyghmi-1.5.70.ebuild
new file mode 100644
index 000000000000..60628881477b
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.70.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest