summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2016-11-10 10:09:10 +0100
committerMarek Szuba <marecki@gentoo.org>2016-11-10 10:10:22 +0100
commitb8f5f425809c074f2e6fa259c5b2264e8d44fe62 (patch)
tree9ab03359269f15ad1caa10d8187633a3d6609571 /dev-python/pyicu/files
parentdev-python/pycodestyle: Version bump for 2.1.0 (diff)
downloadgentoo-b8f5f425809c074f2e6fa259c5b2264e8d44fe62.tar.gz
gentoo-b8f5f425809c074f2e6fa259c5b2264e8d44fe62.tar.bz2
gentoo-b8f5f425809c074f2e6fa259c5b2264e8d44fe62.zip
dev-python/pyicu: version bump to 1.9.4.
Includes backported icu-58.1 support from master. Gentoo-Bug: 599102 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/pyicu/files')
-rw-r--r--dev-python/pyicu/files/pyicu-1.9.4-exclude_libicule.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyicu/files/pyicu-1.9.4-exclude_libicule.patch b/dev-python/pyicu/files/pyicu-1.9.4-exclude_libicule.patch
new file mode 100644
index 000000000000..3da53af033bd
--- /dev/null
+++ b/dev-python/pyicu/files/pyicu-1.9.4-exclude_libicule.patch
@@ -0,0 +1,46 @@
+diff --git a/setup.py b/setup.py
+index 2cbec9f..ea42e96 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,5 +1,5 @@
+
+-import os, sys
++import os, sys, subprocess
+
+ try:
+ from setuptools import setup, Extension
+@@ -8,6 +8,7 @@ except ImportError:
+
+
+ VERSION = '1.9.4'
++ICU_VERSION = subprocess.check_output(('icu-config', '--version')).strip()
+
+ INCLUDES = {
+ 'darwin': ['/usr/local/include'],
+@@ -43,11 +44,11 @@ LFLAGS = {
+ }
+
+ LIBRARIES = {
+- 'darwin': ['icui18n', 'icuuc', 'icudata', 'icule'],
+- 'linux': ['icui18n', 'icuuc', 'icudata', 'icule'],
+- 'freebsd': ['icui18n', 'icuuc', 'icudata', 'icule'],
+- 'win32': ['icuin', 'icuuc', 'icudt', 'icule'],
+- 'sunos5': ['icui18n', 'icuuc', 'icudata', 'icule'],
++ 'darwin': ['icui18n', 'icuuc', 'icudata'],
++ 'linux': ['icui18n', 'icuuc', 'icudata'],
++ 'freebsd': ['icui18n', 'icuuc', 'icudata'],
++ 'win32': ['icuin', 'icuuc', 'icudt'],
++ 'sunos5': ['icui18n', 'icuuc', 'icudata'],
+ }
+
+ platform = sys.platform
+@@ -79,6 +80,9 @@ else:
+
+ if 'PYICU_LIBRARIES' in os.environ:
+ _libraries = os.environ['PYICU_LIBRARIES'].split(os.pathsep)
++elif ((sys.version_info >= (3,) and str(ICU_VERSION, 'ascii') < '58') or
++ (sys.version_info < (3,) and ICU_VERSION < '58')):
++ _libraries = LIBRARIES[platform][:] + ['icule']
+ else:
+ _libraries = LIBRARIES[platform]
+