summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-06-22 12:57:33 +0200
committerSam James <sam@gentoo.org>2021-06-22 19:35:07 +0100
commit99956560ab25b69d46b124327808015da988e7a2 (patch)
tree31666dc766d190d50cc68bd68b902749d7e3715f /dev-python/pyilmbase/files
parentmedia-libs/openexr: bump to 2.5.7 (diff)
downloadgentoo-99956560ab25b69d46b124327808015da988e7a2.tar.gz
gentoo-99956560ab25b69d46b124327808015da988e7a2.tar.bz2
gentoo-99956560ab25b69d46b124327808015da988e7a2.zip
dev-python/pyilmbase: bump to 2.5.7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/21373 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase/files')
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.5.7-0001-disable-py2-for-boost.patch25
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.5.7-0002-install-imathnumpy.so.patch22
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.5.7-0003-fix-pkgconfig-file.patch30
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.5.7-0001-disable-py2-for-boost.patch b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0001-disable-py2-for-boost.patch
new file mode 100644
index 000000000000..73281e5ad6d0
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0001-disable-py2-for-boost.patch
@@ -0,0 +1,25 @@
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Tue, 22 Jun 2021 11:08:15 +0200
+Subject: [PATCH] disable py2 for boost
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 291b96e..68b280d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -142,8 +142,6 @@ endif()
+
+ find_package(Boost OPTIONAL_COMPONENTS
+ python
+- python2
+- ${PYILMBASE_BOOST_PY2_COMPONENT}
+ python3
+ ${PYILMBASE_BOOST_PY3_COMPONENT})
+ set(_pyilmbase_have_perver_boost)
+--
+2.32.0
+
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.5.7-0002-install-imathnumpy.so.patch b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0002-install-imathnumpy.so.patch
new file mode 100644
index 000000000000..1aa4152dbbe5
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0002-install-imathnumpy.so.patch
@@ -0,0 +1,22 @@
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Tue, 22 Jun 2021 11:46:30 +0200
+Subject: [PATCH 1/2] install imathnumpy.so
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ PyImathNumpy/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/PyImathNumpy/CMakeLists.txt b/PyImathNumpy/CMakeLists.txt
+index 7a70f06..2822127 100644
+--- a/PyImathNumpy/CMakeLists.txt
++++ b/PyImathNumpy/CMakeLists.txt
+@@ -49,4 +49,5 @@ if(TARGET Python3::Python AND
+ LIBRARY_OUTPUT_NAME "imathnumpy"
+ DEBUG_POSTFIX ""
+ )
++ install(TARGETS imathnumpy_python3 DESTINATION ${PyIlmBase_Python3_SITEARCH_REL})
+ endif()
+--
+2.32.0
+
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.5.7-0003-fix-pkgconfig-file.patch b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0003-fix-pkgconfig-file.patch
new file mode 100644
index 000000000000..a28757cbf1dc
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.5.7-0003-fix-pkgconfig-file.patch
@@ -0,0 +1,30 @@
+From 7469db402e2affb094585c374518765c69af703d Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Tue, 22 Jun 2021 11:47:01 +0200
+Subject: [PATCH 2/2] fix pkgconfig file
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ config/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
+index a4139bc..45dcca4 100644
+--- a/config/CMakeLists.txt
++++ b/config/CMakeLists.txt
+@@ -15,9 +15,9 @@ if(PYILMBASE_INSTALL_PKG_CONFIG)
+ # use a helper function to avoid variable pollution, but pretty simple
+ function(pyilmbase_pkg_config_help pcinfile)
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
+- set(libdir ${CMAKE_INSTALL_LIBDIR})
+- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
++ set(exec_prefix "\${prefix}")
++ set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
++ set(includedir "\${prefix}/${CMAKE_INSTALL_INCLUDEDIR}")
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
+ set(LIB_SUFFIX_DASH ${OPENEXR_LIB_SUFFIX}${CMAKE_${uppercase_CMAKE_BUILD_TYPE}_POSTFIX})
+ string(REPLACE ".in" "" pcout ${pcinfile})
+--
+2.32.0
+