summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:29:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:30:45 +0300
commitfe95e4b9959c57fd5cdd7ee51e8628c22a19a83f (patch)
treec25b7a27300afa7c93798ce923ddf94bb5ff10c0 /dev-python/pylast
parentdev-python/cfn-lint: add 0.69.0 (diff)
downloadgentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.tar.gz
gentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.tar.bz2
gentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.zip
dev-python/pylast: add 5.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-5.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index e66544e65c5f..f4cae4d24b44 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-5.0.0.tar.gz 39868 BLAKE2B 0cb6d96ac74a2e62325b8a91cc3601ab4ea7ea629ef40c02ce1afe13fd067abc48f24092138fc4584382c9c7f8c62eb070f1a3173b39768ac4ff8e3904c255d2 SHA512 ebad77e66d39b5625d0afae3bba346769159f39dfbbca0fea6aa0e6ad683fea6ea04093dd4738e378ac419edcc9970e8070d7ff912cc08110a5f41f7993489ce
+DIST pylast-5.1.0.gh.tar.gz 40178 BLAKE2B f290afa72d71cb2f88793aaa31aa059a603375e91b310c3ca9180ed5626c589f3d91ae1961db15e256b01bd019b8e59dd48be45ff96683707c05ee9170dfed84 SHA512 64c71f5365638f3bdb435ac2d7405bd1e7a3ebe95fee97469c64bee63ad9850d45781756ebd59942c70780830fbb0519874908d2894e227acadedb5120c3b9ab
diff --git a/dev-python/pylast/pylast-5.1.0.ebuild b/dev-python/pylast/pylast-5.1.0.ebuild
new file mode 100644
index 000000000000..07ac0a967207
--- /dev/null
+++ b/dev-python/pylast/pylast-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+SRC_URI="
+ https://github.com/pylast/pylast/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}