summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-11 18:05:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-11 18:42:07 +0100
commitcb32e23668a11e74d39614eb6fbf8349b7dfa41f (patch)
treea1cb7ecc4baf5a9773552ff15282f81678d8ce55 /dev-python/pylint
parentdev-python/jupyter-server-terminals: Bump to 0.5.0 (diff)
downloadgentoo-cb32e23668a11e74d39614eb6fbf8349b7dfa41f.tar.gz
gentoo-cb32e23668a11e74d39614eb6fbf8349b7dfa41f.tar.bz2
gentoo-cb32e23668a11e74d39614eb6fbf8349b7dfa41f.zip
dev-python/pylint: Bump to 3.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-3.0.3.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index c6fa62731e57..d84d735ce541 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-3.0.2.gh.tar.gz 1420866 BLAKE2B 2679810940ee5b4a4dcde5a4a3d70052901d6ca8dfd025708fdfe3fadffc7713d3507eaea9a67a2fc0748478e8b6e2c2e66e487bf93749fcd9fea7d070197b16 SHA512 923fab3681aa266aa633cc122cd2076dc73588191ed116da0e83d9d0cff253c93634dd420d32b5ea780c25a8e9ff526d8393d4eae2e046a2ff82df3f5f9322a4
+DIST pylint-3.0.3.gh.tar.gz 1422200 BLAKE2B 999afa1a26cc9fdc8f88bc7a1173c4621f608321b09798de7dd30ef3f5fa295b354ae17acf52009dc340a527f2414f350777ea5893a522f44a31baa466242c63 SHA512 ac5fe236bab08cdacdf9fb78cbf444348bfaa4a359dabd17bfdef5d8a7d9b72a794fd5e7483ea326d1c006668fbd6c37d0aa1f8e7c9963bc75265eb9ced6d43b
diff --git a/dev-python/pylint/pylint-3.0.3.ebuild b/dev-python/pylint/pylint-3.0.3.ebuild
new file mode 100644
index 000000000000..0bdc5b7ba65f
--- /dev/null
+++ b/dev-python/pylint/pylint-3.0.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-3.1[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+
+ # incompatible versions of numpy/scikit-learn?
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}