summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-17 07:59:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-17 09:34:54 +0200
commit9cc0758cadc66db5f5e20e344c5b9b3e6955d7f7 (patch)
tree8c438f6db86895e73499ea1ba134bcc28baca725 /dev-python/pypdf/pypdf-3.12.2.ebuild
parentdev-python/asteval: Bump to 0.9.31 (diff)
downloadgentoo-9cc0758cadc66db5f5e20e344c5b9b3e6955d7f7.tar.gz
gentoo-9cc0758cadc66db5f5e20e344c5b9b3e6955d7f7.tar.bz2
gentoo-9cc0758cadc66db5f5e20e344c5b9b3e6955d7f7.zip
dev-python/pypdf: Bump to 3.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypdf/pypdf-3.12.2.ebuild')
-rw-r--r--dev-python/pypdf/pypdf-3.12.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pypdf/pypdf-3.12.2.ebuild b/dev-python/pypdf/pypdf-3.12.2.ebuild
new file mode 100644
index 000000000000..daa02ffcff0c
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.12.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=2cf1e75af7bcb9c097deae6fb112c715d4721744
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}