summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-22 10:07:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-22 10:19:09 +0200
commit1db64a5d6c2cee8155d17bbc1ee72771338a686b (patch)
tree7337bd83b3a94167a8acdca2ce5c096e045e9741 /dev-python/pyproj
parentdev-util/mingw64-runtime: drop 8.0.0-r0, 8.0.0-r1, 9.0.0-r0 (diff)
downloadgentoo-1db64a5d6c2cee8155d17bbc1ee72771338a686b.tar.gz
gentoo-1db64a5d6c2cee8155d17bbc1ee72771338a686b.tar.bz2
gentoo-1db64a5d6c2cee8155d17bbc1ee72771338a686b.zip
dev-python/pyproj: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.3.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index b947ee1842f6..09972e7ede14 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-3.3.0.tar.gz 217539 BLAKE2B 14e2332ffdf3d67e531bb4809cd50fd4902828b0cc3d2427921624d56cf05bdc0f3d5b17ea0516b3f428ad82bc57df840e4bd2dde1232870c9b959c34998c254 SHA512 9e8429a4fbec1950bf72a8c582d4a944a6707ac54a107a7837bf7fe44f8c2e29f1f6d0dcd9f5ff3ef511f3d31016389745cc2dfc14e2089756e6e72fe6074c47
+DIST pyproj-3.3.1.gh.tar.gz 238373 BLAKE2B 7996d253a35e3d64a343141179a88d2ab97e88f96447f3daf14c9f8d731099b506228c163fe460d3be30ae69c87e908879b3c0fe31eb7624c3bb8da157838337 SHA512 7175479f4ec526ada830d178bea77552d66aace4c7f6cde584aebef5fc4c6b7a46272eea2bd95f71910411c9ac8d8832d350891ffffda8a86eabb5449177a5eb
diff --git a/dev-python/pyproj/pyproj-3.3.1.ebuild b/dev-python/pyproj/pyproj-3.3.1.ebuild
new file mode 100644
index 000000000000..c8ba64083b68
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="
+ https://github.com/pyproj4/pyproj/
+ https://pypi.org/project/pyproj/
+"
+SRC_URI="
+ https://github.com/pyproj4/pyproj/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND="
+ >=sci-libs/proj-8.0.0:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pyproj || die
+ epytest -m "not network" test
+}