summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-19 05:52:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-19 06:27:47 +0200
commit4e3c6f2dda79755fc2af01720daad1ec01eb4e55 (patch)
tree59306c123ab512deffe0b1181aa3d37a5e70f64d /dev-python/pyproject-api
parentdev-python/sympy: Bump to 1.13.3 (diff)
downloadgentoo-4e3c6f2dda79755fc2af01720daad1ec01eb4e55.tar.gz
gentoo-4e3c6f2dda79755fc2af01720daad1ec01eb4e55.tar.bz2
gentoo-4e3c6f2dda79755fc2af01720daad1ec01eb4e55.zip
dev-python/pyproject-api: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-api')
-rw-r--r--dev-python/pyproject-api/Manifest1
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.8.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index 0656caa03f82..559eb8fd6b19 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1,2 +1,3 @@
DIST pyproject_api-1.7.1.tar.gz 22271 BLAKE2B 833001e4638594e61ba8dd97e2e62dffd25650cc30cbcdb9367f09605e128733d7c8945afeadc5ba16d15e932da0cc60eee2715eeef21290c04a73f74165e748 SHA512 e016d612578f46dbb5ab9d406d01513d8e1528524dcb58c4ebe76c5d7518289da187bed0e500d382b37aaac0e38236d54a88e7cc1f3a2a6876088b26d17337a8
DIST pyproject_api-1.7.2.tar.gz 22353 BLAKE2B 483400bd8c79da5e3eb54ee42bcb74e6507824f3f7bfcbf5a9172c942af7488dd9896e55eba8b4153e250ddc549df8e0f56576e63b6ce472c1bbc2e0ea8ae344 SHA512 4e331249e0a6e38bcf0baa4143c0fef455e91e3b1c422233b813aa3fcbe81a7f67ce3c6f969a313e636ae19dbc4192e59add946fb57dc43907d27538116573d8
+DIST pyproject_api-1.8.0.tar.gz 22340 BLAKE2B 7087b04045870ab6ec62dbd93ca59fbab6a9200f1eb20140ac28355b6f88a719961949f06c1cb888b4ef2d9ad61c2f533cf4e361c64e34c04faf6d0db7762090 SHA512 9a598179cb31694c862a91040c453d767ecbddd7aed4156f044d6684316294e962bdaaff646cd8c9cf15af204efc9a03dbc781058610c334c7ea2f2df54f1883
diff --git a/dev-python/pyproject-api/pyproject-api-1.8.0.ebuild b/dev-python/pyproject-api/pyproject-api-1.8.0.ebuild
new file mode 100644
index 000000000000..7ebc016f7130
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-24.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.11.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-68.1.2[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # hardcodes assumptions specific to setuptools-70.1.0
+ tests/test_frontend_setuptools.py::test_setuptools_get_requires_for_build_wheel
+ # some minor formatting mismatch
+ tests/test_frontend_setuptools.py::test_setuptools_prepare_metadata_for_build_wheel
+)