summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 21:34:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 21:37:47 +0200
commite192e47c76518b6982bb02c107aa8d0264004c7d (patch)
treeff5b2894d2387f6991cdbee049bae9d68e4efdde /dev-python/pyqtgraph
parentsys-libs/compiler-rt-sanitizers: fix patchset version (diff)
downloadgentoo-e192e47c76518b6982bb02c107aa8d0264004c7d.tar.gz
gentoo-e192e47c76518b6982bb02c107aa8d0264004c7d.tar.bz2
gentoo-e192e47c76518b6982bb02c107aa8d0264004c7d.zip
dev-python/pyqtgraph: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest1
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.3.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index b622ff82abf1..6066acd8775b 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,3 +1,2 @@
-DIST pyqtgraph-0.12.3.tar.gz 1317230 BLAKE2B d9a7a86f976fd7d778b0f038b24e80d6cbbdb98f6cda7de0461d1e3bbac0a99745dc3cccc63f38c24128018a2f41f3a0da7437bf9ddbd3f4091fd826ae4ea915 SHA512 13f1ff4bcce7ab8c133ebb99101d300bb3abcd6ea8b7321f3aa646d6992b6988db17d478dcec52339dd380f7c6e487f47b95b9f9de616b7ff2dab35ca5f0cc30
DIST pyqtgraph-0.12.4.tar.gz 1333052 BLAKE2B 4208787d1d203904d841493e10b2f1d23357b60475c9e1cfff733fe772973d4dd619ca84941049bd60299912f3077fb18c27a90fa3c0c0e712a3715b5be1d071 SHA512 8402b38fe1abaaf55d6dbc26775093993b9f642d7a9da59d2780ed38562c8653ab872c588d2e66373434491b8f397533cb3c222382065c812a28cf6b9ce34960
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.3.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.3.ebuild
deleted file mode 100644
index 20b3a3e7229d..000000000000
--- a/dev-python/pyqtgraph/pyqtgraph-0.12.3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 multiprocessing
-
-TEST_DATA_TAG=test-data-8
-DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
-HOMEPAGE="https://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
-SRC_URI="
- https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
- test? (
- https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
- -> ${PN}-${TEST_DATA_TAG}.tar.gz
- )"
-S=${WORKDIR}/${PN}-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples opengl svg"
-REQUIRED_USE="test? ( opengl svg )"
-
-RDEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? (
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytest-xvfb[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if ! use opengl; then
- rm -r pyqtgraph/opengl || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # apparently fragile
- tests/test_reload.py::test_reload
-
- # TODO
- tests/graphicsItems/test_ROI.py::test_PolyLineROI
-
- # pyside2 is normally skipped if not installed but these two
- # fail if it is installed
- # TODO: this could be due to USE flags, revisit when pyside2
- # gains py3.9
- 'examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
- 'examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
- )
-
- distutils_install_for_testing
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-src_test() {
- mkdir "${HOME}"/.pyqtgraph || die
- mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
- "${HOME}"/.pyqtgraph/test-data || die
- cd "${HOME}"/.pyqtgraph/test-data || die
- # we need to fake a git repo
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git init -q || die
- git commit -q --allow-empty -m "dummy commit" || die
- git tag "${TEST_DATA_TAG}" || die
- cd - >/dev/null || die
-
- distutils-r1_src_test
-}
-
-python_install_all() {
- use examples && DOCS+=( examples/ )
- distutils-r1_python_install_all
-}