summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-10 21:00:40 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-10 21:01:03 -0600
commit908a711df2180e3cbcdf8ec873bbe7bf809135db (patch)
treeca3af1f8ee7e107d3ceea34f4891e929e9ad96ae /dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild
parentdev-libs/icu-layoutex: amd64 stable (diff)
downloadgentoo-908a711df2180e3cbcdf8ec873bbe7bf809135db.tar.gz
gentoo-908a711df2180e3cbcdf8ec873bbe7bf809135db.tar.bz2
gentoo-908a711df2180e3cbcdf8ec873bbe7bf809135db.zip
dev-python/pysaml2: fix xxe in pysaml2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild')
-rw-r--r--dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild b/dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..69aac4c21ed1
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-4.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/xxe-4.0.2.patch" )
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/repoze-who[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"