summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-26 05:05:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-26 05:26:24 +0200
commit0d0f7ab62953a884ae26e0a84df16f0e711ae2db (patch)
tree8217b8509019f36d5eb56a7f4cae0999a2a7e431 /dev-python/pyspnego
parentapp-emulation/qemu-guest-agent: add python3_11 (diff)
downloadgentoo-0d0f7ab62953a884ae26e0a84df16f0e711ae2db.tar.gz
gentoo-0d0f7ab62953a884ae26e0a84df16f0e711ae2db.tar.bz2
gentoo-0d0f7ab62953a884ae26e0a84df16f0e711ae2db.zip
dev-python/pyspnego: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.6.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index d53b3586b777..611eca20be09 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1 +1,2 @@
DIST pyspnego-0.6.0.tar.gz 200621 BLAKE2B cb6b44ccfb87600c480f67ddae686a424ad75a7f16c8f78d3539159c523069b71c534a3dfb8ec06ee26b75261d87d54e8b96aaa2d0f477f2488438075d6212a5 SHA512 65f877a2fcff4671606063223d1499be19368040a0f70d0d9363dd84c0b09a195a5e6bc7da1d3745fbf81af822f20f3d903ca2a9372898a2973ba93b6661a708
+DIST pyspnego-0.6.1.tar.gz 200508 BLAKE2B e284b42da97919a63a5ff51687cdd0d8891492ab2e296686b88242fb4db6326ac56c5b04488e47be04764c75fefdf2a9073cc8983150f6d0e5d4819bd49fa86d SHA512 eab37ad3691da06e91221107483c2ae4504d4e7f3b7d288843387dbe2c8611b3839b6cf378b2418b977f835fc5a4ea4b9a8b9995d9ee07d25069fea05bc4b876
diff --git a/dev-python/pyspnego/pyspnego-0.6.1.ebuild b/dev-python/pyspnego/pyspnego-0.6.1.ebuild
new file mode 100644
index 000000000000..372520083949
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}