summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 06:41:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 06:41:02 +0200
commit5b40db0aa5d173c29f3ca97c953908d1d6741a16 (patch)
tree6a3f459fc6bcaf934d00d2f0294cf8925f1138f5 /dev-python/pyspnego
parentdev-python/braintree: Bump to 4.29.0 (diff)
downloadgentoo-5b40db0aa5d173c29f3ca97c953908d1d6741a16.tar.gz
gentoo-5b40db0aa5d173c29f3ca97c953908d1d6741a16.tar.bz2
gentoo-5b40db0aa5d173c29f3ca97c953908d1d6741a16.zip
dev-python/pyspnego: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.11.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 2afd86dc2801..389a19d6cfc8 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1 +1,2 @@
DIST pyspnego-0.11.0.tar.gz 225609 BLAKE2B 580ba1eb5a36af973af5acd6421ea373597961fe35e8f32c1cdd7938f550e0e20307a540405182761181927ebb69822dd289170ffe5110a8b49bfc4cc4f99f01 SHA512 7717dfbca4cd40f71f6aa436ed3f23f4cfd77c50569af90dd2f4b337cf46b485b8046fc5b2ded6a77c54af2ef3fca28e085616e900e25d8830b3600cbd3e44b5
+DIST pyspnego-0.11.1.tar.gz 225697 BLAKE2B fae4a4873bb7d84076c3703398f7dbb8ce27712804430290232239fef06e9c5b3a30ef397e82f109d6b4dcc61682cdb87d6469c5a1d323818dd16194fcc3b2df SHA512 3fac72600e162aed20d888727d74f67a7f1ae44aa000e0290c25e66a86d37bf2afb0718b36084926316149cb5157affe8beac65507b4d6e924d810c9aa6d86dc
diff --git a/dev-python/pyspnego/pyspnego-0.11.1.ebuild b/dev-python/pyspnego/pyspnego-0.11.1.ebuild
new file mode 100644
index 000000000000..d4c182cc408c
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}