summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-04 07:29:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-04 07:51:19 +0200
commitd344b5c119b60df76bde61f5d1c0d7b35b8b6d96 (patch)
tree8bcb57a787efa21ec787cca6e6fb9e4bd0a4e907 /dev-python/pyspnego
parentdev-python/setproctitle: Bump to 1.3.3 (diff)
downloadgentoo-d344b5c119b60df76bde61f5d1c0d7b35b8b6d96.tar.gz
gentoo-d344b5c119b60df76bde61f5d1c0d7b35b8b6d96.tar.bz2
gentoo-d344b5c119b60df76bde61f5d1c0d7b35b8b6d96.zip
dev-python/pyspnego: Bump to 0.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.10.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 9fb842d68e17..d6fb638f442c 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1,2 +1,3 @@
DIST pyspnego-0.10.0.tar.gz 221948 BLAKE2B b98ec74c4e0896a27ef718a426bd030113b57397b5fc8337d826a71dc3ff5068b95c8ee439615c7ab067ed4caf8f5801f3430bd3dce67286a14952e7797c2941 SHA512 4ab2c1e51c1e79a9b241600aa40d4a0ed70958d4cd9c2dba0f11e02e980810c0bc67cdb89b10eea3c42c84dcb8f98e284c108cfee75ae87a3107870cab854209
DIST pyspnego-0.10.1.tar.gz 222011 BLAKE2B d7089023cf968029d6ec29216bda154824f19a504ab76ad9f3032fcb6c821ca67435bff7c54a86a881fd802787433e61530a458b797d8c91d19ae25b8766b016 SHA512 881291d3d5f81d0970f1b2cea201c055baf3973aae84cf15995e6f2c5a0ac8a23686e49b163f7d85b8fd0226f98de59bafc939c6983d1a81e954a3f22b34714e
+DIST pyspnego-0.10.2.tar.gz 222036 BLAKE2B b46c5469e7f764342f1510d54ee307ec57c6d999d2beb013fdc18eb06d56d601b3f035f0a9d9f9f5a656719f19a345ee25ca8664084afac3dd42529ae53dcf4a SHA512 9d5b45a9c4c2c929269f5eceaa05fbe34571e518b289b165049ddb7fd2bb207c7e6074c45216ad0cdf20e4be7bfca2f3d497aba45e2aadceb0b75221edc54f5d
diff --git a/dev-python/pyspnego/pyspnego-0.10.2.ebuild b/dev-python/pyspnego/pyspnego-0.10.2.ebuild
new file mode 100644
index 000000000000..408e9482cad6
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}