summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:37 +0200
commit857da9112e78e0310c897f71c876f015c407e544 (patch)
treeab55daec52a221ecccbc9fc5fadabdb5a80f431f /dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
parentdev-python/pytest-aiohttp: Remove redundant versions (diff)
downloadgentoo-857da9112e78e0310c897f71c876f015c407e544.tar.gz
gentoo-857da9112e78e0310c897f71c876f015c407e544.tar.bz2
gentoo-857da9112e78e0310c897f71c876f015c407e544.zip
dev-python/pytest-asyncio: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
deleted file mode 100644
index b5141f97fa04..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
- https://pypi.org/project/pytest-asyncio/"
-SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/async_generator[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/pytest-asyncio-0.10.0-py38.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}