summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-22 11:13:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-22 11:16:35 +0200
commit9fbb3278d6b1d5c2807ef7b9c2865977b46a2673 (patch)
treeb9ab6255bdb1b1184129403565c1bbfc1cf7bc22 /dev-python/pytest-asyncio
parentdev-python/widgetsnbextension: Remove old (diff)
downloadgentoo-9fbb3278d6b1d5c2807ef7b9c2865977b46a2673.tar.gz
gentoo-9fbb3278d6b1d5c2807ef7b9c2865977b46a2673.tar.bz2
gentoo-9fbb3278d6b1d5c2807ef7b9c2865977b46a2673.zip
dev-python/pytest-asyncio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 58f880ef05e9..4c54b25352cc 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,2 +1 @@
-DIST pytest-asyncio-0.20.3.gh.tar.gz 27695 BLAKE2B 6e6f0d58d0f985cee9dc0b27f886d0b1b4b54ecbf4980c4ac59b420d6e6e5c01d1c6f3c9ed803391910124f19ee3a882c963f10e5f6bab6de6115bfa222c8be2 SHA512 78a6e251db80696d6f62a54c8d6836e2a820f27efdaa848eb1be512a1592d3bd3fb7c7eee46bb2039a317a8d431565614c888f8436fbe0d4eb60534ce4780e90
DIST pytest-asyncio-0.21.0.tar.gz 29898 BLAKE2B 6455e59a2e28ddbefd54e4c16970d36d22a674406fbc0e352e9886af3a7a51a0ae4a8ce32e01d076e2411f0501548092dfbe3150d87c14cb5e5eb71966bcb743 SHA512 ce557e5f15f3ae745804f4484d590a9f673d76f0c67c2e8ab444e1b17a4ae5ea6021bf55d7ef905643bfbcded6299f207a386fb4dc05ddf20ade25e6618a9773
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild
deleted file mode 100644
index ef714a839b36..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.20.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/test_pytest_min_version_warning.py
- tests/modes/test_legacy_mode.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
- epytest
-}