summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-09 18:41:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-09 18:44:19 +0100
commit4055ce75aa86ab798bb9acb63d951599fb069f05 (patch)
tree5fbf730a4e7efcf5f33b8c10e973a5858a41bd24 /dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
parentdev-python/pypy3: Backport IDNA dec secfix to 7.3.9_p9 (diff)
downloadgentoo-4055ce75aa86ab798bb9acb63d951599fb069f05.tar.gz
gentoo-4055ce75aa86ab798bb9acb63d951599fb069f05.tar.bz2
gentoo-4055ce75aa86ab798bb9acb63d951599fb069f05.zip
dev-python/pytest-bdd: Bump to 6.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild')
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
new file mode 100644
index 000000000000..5887f2b6c792
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-bdd/
+ https://pypi.org/project/pytest-bdd/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}