summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-22 16:50:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-22 17:01:06 +0200
commitf9a6c1bba8f884022c5611e42a1167047ebd3da5 (patch)
treee1df54efdba49b681ef486633c20fedc481c9171 /dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild
parentdev-python/botocore: Remove old (diff)
downloadgentoo-f9a6c1bba8f884022c5611e42a1167047ebd3da5.tar.gz
gentoo-f9a6c1bba8f884022c5611e42a1167047ebd3da5.tar.bz2
gentoo-f9a6c1bba8f884022c5611e42a1167047ebd3da5.zip
dev-python/pytest-bdd: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild')
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild
deleted file mode 100644
index 51e3319ece59..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}