summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-09 14:16:35 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-09 14:18:59 -0500
commit4f3ccc1ca84437bbc8104de16d1f6a2842eba8cd (patch)
tree7de6b4d73dd7c4017ffab939f680a0a053ddb3d5 /dev-python/pytest-bdd
parentwww-servers/varnish: add github upstream metadata (diff)
downloadgentoo-4f3ccc1ca84437bbc8104de16d1f6a2842eba8cd.tar.gz
gentoo-4f3ccc1ca84437bbc8104de16d1f6a2842eba8cd.tar.bz2
gentoo-4f3ccc1ca84437bbc8104de16d1f6a2842eba8cd.zip
dev-python/pytest-bdd: revert style changes
While I don't mind others touching my package, I'd appreciate no style changes. Had hoped to bump it yesterday to avoid that but tag was missing on github. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild20
1 files changed, 4 insertions, 16 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
index 5887f2b6c792..5d7b8445abb2 100644
--- a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
@@ -5,18 +5,11 @@ EAPI=8
DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..11} )
-
inherit distutils-r1
DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-bdd/
- https://pypi.org/project/pytest-bdd/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -27,13 +20,8 @@ RDEPEND="
dev-python/parse[${PYTHON_USEDEP}]
dev-python/parse_type[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )
-"
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest