summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-07 00:56:01 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-07 01:47:57 -0500
commite99da0d98c50b6ca96ab088a0bc390b1a993f25e (patch)
treec7d2bed55af4d08fe15b2c7f2114d6a9fed3ee43 /dev-python/pytest-bdd
parentwww-client/qutebrowser: drop 3.3.1 (diff)
downloadgentoo-e99da0d98c50b6ca96ab088a0bc390b1a993f25e.tar.gz
gentoo-e99da0d98c50b6ca96ab088a0bc390b1a993f25e.tar.bz2
gentoo-e99da0d98c50b6ca96ab088a0bc390b1a993f25e.zip
dev-python/pytest-bdd: drop 7.3.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 720e1d846267..ed6d832096fb 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,2 +1 @@
-DIST pytest-bdd-7.3.0.gh.tar.gz 81595 BLAKE2B 80c5323ba3c50fae17bb57ec26b968ca7d7b673d2aeb2716dee02e3543916ca8b5752d9af56d3d250f3a4b0a857a3dc760de615f0650eaf379380fb24a5b7c2a SHA512 e7c309552714a77d47e437a825e661dbf201a6945e84f4b611b5c3da3d0b4ceb535bde4809fc9633b82a74e2b52cc69c7e14b27a27032c7e4400727498442e29
DIST pytest-bdd-8.1.0.gh.tar.gz 116529 BLAKE2B b282f42dbde9394f37e41682d44352d5895a30e2b88c20c46f8d9344f8069e25e2a7a2b6225ebd34a43b60d2392c7bc515f2ebd94bb26a0d350b7d188dd4d77e SHA512 6b03a509a8026ac242a4446caffc019b264f3528322eab8aa0ca2ce4c099bbc45640d63087a756d0d1d0daacdd2f396f121823ca500cef38391e9313a0f898ab
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
deleted file mode 100644
index 8123e325faa8..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse-type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}