summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 21:13:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 22:00:30 +0100
commit40ce7e923ae7e606a5347c30db8a3295dd171fe9 (patch)
tree734c269da56aa1dc2365943fdde8bad06f16aad8 /dev-python/pytest-cov/files
parentdev-python/django-tables2: drop old version (diff)
downloadgentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.tar.gz
gentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.tar.bz2
gentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov/files')
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch20
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch40
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch52
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
deleted file mode 100644
index 660db5e59431..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index e79e9aa..e5ef2c1 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -820,6 +820,7 @@ parallel = true
- assert result.ret == 0
-
-
-+@pytest.mark.skip(reason="test is broken")
- def test_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
- stuff = testdir.mkdir('stuff')
- parent_script = stuff.join('parent_script.py')
-@@ -951,6 +952,7 @@ def test_invalid_coverage_source(testdir):
- assert not matching_lines
-
-
-+@pytest.mark.skip(reason="test is broken")
- @pytest.mark.skipif("'dev' in pytest.__version__")
- @pytest.mark.skipif('sys.platform == "win32" and platform.python_implementation() == "PyPy"')
- def test_dist_missing_data(testdir):
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
deleted file mode 100644
index 8a9618c3fd98..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 1305b23..3a5803e 100644
---- a/setup.py
-+++ b/setup.py
-@@ -29,7 +29,7 @@ def read(*names, **kwargs):
-
-
- class BuildWithPTH(build):
-- def run(self):
-+ def run(self, **kwargs):
- build.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.build_lib, basename(path))
-@@ -37,7 +37,7 @@ class BuildWithPTH(build):
-
-
- class EasyInstallWithPTH(easy_install):
-- def run(self):
-+ def run(self, **kwargs):
- easy_install.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
-@@ -45,7 +45,7 @@ class EasyInstallWithPTH(easy_install):
-
-
- class InstallLibWithPTH(install_lib):
-- def run(self):
-+ def run(self, **kwargs):
- install_lib.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
-@@ -57,7 +57,7 @@ class InstallLibWithPTH(install_lib):
-
-
- class DevelopWithPTH(develop):
-- def run(self):
-+ def run(self, **kwargs):
- develop.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
deleted file mode 100644
index 6292672b6191..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index e79e9aa..198478b 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -662,6 +662,7 @@ def test_fail(p):
- ])
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="Seems buggy on python3.8")
- @pytest.mark.skipif('sys.platform == "win32" or platform.python_implementation() == "PyPy"')
- def test_dist_combine_racecondition(testdir):
- script = testdir.makepyfile("""
-@@ -1018,6 +1019,7 @@ def test_funcarg_not_active(testdir):
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif("sys.version_info[0] < 3", reason="no context manager api on Python 2")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
-@@ -1059,6 +1061,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
- def test_multiprocessing_pool_terminate(testdir):
-@@ -1141,6 +1144,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process(testdir):
- pytest.importorskip('multiprocessing.util')
-@@ -1171,6 +1175,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process_no_source(testdir):
- pytest.importorskip('multiprocessing.util')
-@@ -1201,6 +1206,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process_with_terminate(testdir):
- pytest.importorskip('multiprocessing.util')