summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 08:38:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 08:57:19 +0200
commitee29073edf1410c6708590307da30c30101d7843 (patch)
treef7393f10c86e11d2a0bc34cde8cb4262672f57b6 /dev-python/pytest-describe
parentdev-python/sqlalchemy: Bump to 1.4.23 (diff)
downloadgentoo-ee29073edf1410c6708590307da30c30101d7843.tar.gz
gentoo-ee29073edf1410c6708590307da30c30101d7843.tar.bz2
gentoo-ee29073edf1410c6708590307da30c30101d7843.zip
dev-python/pytest-describe: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-describe')
-rw-r--r--dev-python/pytest-describe/Manifest1
-rw-r--r--dev-python/pytest-describe/pytest-describe-2.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/Manifest b/dev-python/pytest-describe/Manifest
index 682d4446bcb8..badacc490dca 100644
--- a/dev-python/pytest-describe/Manifest
+++ b/dev-python/pytest-describe/Manifest
@@ -1 +1,2 @@
DIST pytest-describe-1.0.0.tar.gz 8917 BLAKE2B 8608a00151273ebb22da6a297580295abbd64c7d9e90bfba9611eac3be64247be20ee43bb64ead1a3f74e65719112a94535506f4402cb7084802360609ab0173 SHA512 1cefa2911e598063b3b9dce381750d204c925cb0dde890b79745c8b4f1cf6d0349f85dc9eaf895000a6f15f45a84fb920f27c01b0af1959125fbe3716cbebbbc
+DIST pytest-describe-2.0.0.tar.gz 9711 BLAKE2B d9a799afebf77166c81a9d2477a378d7664e9aa586460043c9a9448838eafebcb0679768d10d2439ab350b48ad7263ebe17eea6fdaef96ef14aceb6aa9ff943c SHA512 28edd2b10607424aff7b95dd834716fc1888a09c23d810e0b9870a5a93de3ca745d3506a6327ece6f92b3afcdcee0fb56f6f163e2868abcf2022175708ff58af
diff --git a/dev-python/pytest-describe/pytest-describe-2.0.0.ebuild b/dev-python/pytest-describe/pytest-describe-2.0.0.ebuild
new file mode 100644
index 000000000000..b0f2ea97b6db
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-describe/
+ https://pypi.org/project/pytest-describe/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" epytest
+}