summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 18:12:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 19:04:35 +0100
commit527954db480d12e83a0c08411f54333dcba51b73 (patch)
treec402bc8a3bb3616cab53e358325e81f29a5ef903 /dev-python/pytest-django
parentdev-python/traitlets: Bump to 5.13.0 (diff)
downloadgentoo-527954db480d12e83a0c08411f54333dcba51b73.tar.gz
gentoo-527954db480d12e83a0c08411f54333dcba51b73.tar.bz2
gentoo-527954db480d12e83a0c08411f54333dcba51b73.zip
dev-python/pytest-django: Bump to 4.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index b68b63a733a0..cc6911c4e163 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1,2 @@
DIST pytest-django-4.5.2.gh.tar.gz 75429 BLAKE2B 2e8fba037c7618c6dd1c9200c5c44a7b00a13a2d70b4a593a461af3dbc0333b6814ceca16f88a58f1b6aeea2700cac12b589ede702b8eaf023fb3948e0ab8b9a SHA512 09ed5bfe850599e95190d9b15e9383d1249ea575a7b3921744583da6266dd2c8d3eb4f93c8de96d98e1a8e33d1639937470cdc6d11558fcaea57d014dce13500
+DIST pytest-django-4.6.0.gh.tar.gz 77499 BLAKE2B 057eb0f3593aed92285d96edbcff94cab5ec1574c394793199df4b93bfb3256b723ae74689a6413f7a2303b8c5564e40805f4e9ee6ed2dead1030d8da3a4f7ed SHA512 e2dc2a1993b795cc15f6d63757a9c01b2f466812f69f07aa43deff8260edcd881da554a200b0d793173a2fa9efd826f020e2ba1c26931fa2f59503d25ce7c240
diff --git a/dev-python/pytest-django/pytest-django-4.6.0.ebuild b/dev-python/pytest-django/pytest-django-4.6.0.ebuild
new file mode 100644
index 000000000000..9148fdfba396
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for pytest"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/django-configurations-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE
+ local -x PYTHONPATH=${PWD}
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}