summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 07:32:06 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 09:24:57 +0100
commit70a4a503dd369a11e530c7ec511eed90f88cbcc8 (patch)
tree80b5997f03d30ce83356ac3a300cc76910a321df /dev-python/pytest-fixture-config
parentdev-python/pytest-virtualenv: Revbump to drop py2 (diff)
downloadgentoo-70a4a503dd369a11e530c7ec511eed90f88cbcc8.tar.gz
gentoo-70a4a503dd369a11e530c7ec511eed90f88cbcc8.tar.bz2
gentoo-70a4a503dd369a11e530c7ec511eed90f88cbcc8.zip
dev-python/pytest-fixture-config: Revbump to drop py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-fixture-config')
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..8cb9f4650c32
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-fixture-config/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest