summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 11:31:36 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:01 +0000
commitcd45fab88ae77edb82b159020abd80ffa44cd99a (patch)
treee829ea1a5985a0aeee1cb57efefc7e8e05a5322a /dev-python/pytest-flake8
parentdev-python/nosexcover: Port to python 3.{8,9} (diff)
downloadgentoo-cd45fab88ae77edb82b159020abd80ffa44cd99a.tar.gz
gentoo-cd45fab88ae77edb82b159020abd80ffa44cd99a.tar.bz2
gentoo-cd45fab88ae77edb82b159020abd80ffa44cd99a.zip
dev-python/pytest-flake8: Bump to 1.0.7
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest1
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index a0577a1ff53f..3d46e6809e1c 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1 +1,2 @@
DIST pytest-flake8-0.9.1.tar.gz 7959 BLAKE2B d0ef55385dbbf47968abdfc14e69a0420cd52bdf65c0f74ec72abeb1ab28ad27806593dd592f448f3c01dcdf29af4042c1e1c8affde46a1405ba7b4155c174a4 SHA512 eeb4f66022e367d92dee94544ae8fa99b79c1de0579a80e91c22e6f050752010cb7ad6c24094736d23ae753615b186a957b8b0f94c09754005183a971a1e4aa1
+DIST pytest-flake8-1.0.7.tar.gz 9560 BLAKE2B 056066a6693fa6988448662e52856eeed49688e834b344e5f60f31f1c3b3ef89043dba06bddbf958b042ab9e702fec056784b252e96c8b4b46fe350a801535cf SHA512 16e7b437ff9fc9afd3520f6b81d9eafeda840c7cd7925f5287ce0e0d5b20a0fa758183cea7ade369e3fec8606eee976e84c5b3142923e4586f559232012bf3a3
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
new file mode 100644
index 000000000000..84c861885f25
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/pytest-flake8 https://pypi.org/project/pytest-flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.5[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest