summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-16 16:16:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-16 16:22:18 +0200
commit5e7ac875687c56f0fbfce7c6cd62d09cc681a229 (patch)
treef1a47e0c6981647911a52524494e5e760bb392ca /dev-python/pytest-import-check
parentapp-accessibility/at-spi2-core: update HOMEPAGE (diff)
downloadgentoo-5e7ac875687c56f0fbfce7c6cd62d09cc681a229.tar.gz
gentoo-5e7ac875687c56f0fbfce7c6cd62d09cc681a229.tar.bz2
gentoo-5e7ac875687c56f0fbfce7c6cd62d09cc681a229.zip
dev-python/pytest-import-check: Bump to 0.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-import-check')
-rw-r--r--dev-python/pytest-import-check/Manifest1
-rw-r--r--dev-python/pytest-import-check/pytest-import-check-0.0.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-import-check/Manifest b/dev-python/pytest-import-check/Manifest
index 99b6add99604..474e5f6fe7f0 100644
--- a/dev-python/pytest-import-check/Manifest
+++ b/dev-python/pytest-import-check/Manifest
@@ -1 +1,2 @@
DIST pytest_import_check-0.0.1.tar.gz 3019 BLAKE2B 7e34c3aa7b59b1c3af2eccd336cfa6e6b33ac596648c36c1fef647eb9d4f24e560b865fd8b58191f5ae94463f199f855c701f00d48912c73ee8474dfbc32d0b5 SHA512 e582af2017531318bd95acea7c96050a3f5f6373a4c1deeb7aa290e67a068bc46c398279a72dee5ef34c2585ccad75a7d9e74011335b845e86bcb1e9a1adaa2b
+DIST pytest_import_check-0.0.2.tar.gz 16309 BLAKE2B 94e6f9d316194f6765a38ddc97ecb4a9df7d4413077e0f9a1d638b0535920e4d379f2cc538f102176e10cdd54b4b535531e0e9bf02c42c7c085b02a82c3f1a56 SHA512 fd2a5e0bb55d2cb0a3e8d0c6281f05996a4213ffa554636e02660882281af5aa43d759b801853b272b9b572b4c7de6c3c659861f4c4b780907eb8b0e6ec802e1
diff --git a/dev-python/pytest-import-check/pytest-import-check-0.0.2.ebuild b/dev-python/pytest-import-check/pytest-import-check-0.0.2.ebuild
new file mode 100644
index 000000000000..da6f4a6e4e3b
--- /dev/null
+++ b/dev-python/pytest-import-check/pytest-import-check-0.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to check whether Python modules can be imported"
+HOMEPAGE="
+ https://github.com/projg2/pytest-import-check/
+ https://pypi.org/project/pytest-import-check/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-8.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_import_check
+ epytest
+}