summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-28 04:38:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-28 04:50:29 +0200
commitac155195a690c485f1d8011a2b4c03dbbc8a8dc4 (patch)
treef1460e3b970e00aa3ecbbaccefd198051873be4c /dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild
parentdev-python/cachetools: Bump to 5.3.1 (diff)
downloadgentoo-ac155195a690c485f1d8011a2b4c03dbbc8a8dc4.tar.gz
gentoo-ac155195a690c485f1d8011a2b4c03dbbc8a8dc4.tar.bz2
gentoo-ac155195a690c485f1d8011a2b4c03dbbc8a8dc4.zip
dev-python/pytest-metadata: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild b/dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild
new file mode 100644
index 000000000000..3ade758cdf43
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-metadata/
+ https://pypi.org/project/pytest-metadata/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest