summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 14:07:51 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 14:39:55 +0100
commit8e6877194b630f22ef3cce97c43e8725b59e35c8 (patch)
tree9857bdb001817a3c4ba97c02023a6f0770682aa2 /dev-python/pytest-plus
parentdev-python/click-help-colors: initial import (diff)
downloadgentoo-8e6877194b630f22ef3cce97c43e8725b59e35c8.tar.gz
gentoo-8e6877194b630f22ef3cce97c43e8725b59e35c8.tar.bz2
gentoo-8e6877194b630f22ef3cce97c43e8725b59e35c8.zip
dev-python/pytest-plus: initial import
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/metadata.xml13
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.2.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
new file mode 100644
index 000000000000..1b1dc87fd5ca
--- /dev/null
+++ b/dev-python/pytest-plus/Manifest
@@ -0,0 +1 @@
+DIST pytest-plus-0.2.tar.gz 8210 BLAKE2B b8a28e72cfb4e10daa021528de9b5df2e9eb0bc4e911557c7c14a0825284787e94992132c0b74881867a41b55a67785c60b9b87a1594ad33fb57ebac8de391a6 SHA512 e16a03433cb6eb30b6881bec99482bc65cb7d1fa3d0db855befe666c0645d4b5ec02debde9dec4322ed0a0b77d3ac3f1cabda0cf98f375ffd68dc29fb55f5139
diff --git a/dev-python/pytest-plus/metadata.xml b/dev-python/pytest-plus/metadata.xml
new file mode 100644
index 000000000000..11989dba8342
--- /dev/null
+++ b/dev-python/pytest-plus/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-plus</remote-id>
+ <remote-id type="pypi">pytest-plus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-plus/pytest-plus-0.2.ebuild b/dev-python/pytest-plus/pytest-plus-0.2.ebuild
new file mode 100644
index 000000000000..3bd50d2af4a9
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="https://github.com/pytest-dev/pytest-plus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest