summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 09:15:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:41:17 +0100
commit535dd1473a26b98eb89b14c0ce6c2fa917754266 (patch)
treef33e17e494562bb3e22a8eb81dda72b6bd0bccd3 /dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild
parentdev-python/croniter: Bump to 1.3.8 (diff)
downloadgentoo-535dd1473a26b98eb89b14c0ce6c2fa917754266.tar.gz
gentoo-535dd1473a26b98eb89b14c0ce6c2fa917754266.tar.bz2
gentoo-535dd1473a26b98eb89b14c0ce6c2fa917754266.zip
dev-python/pytest-rerunfailures: Bump to 10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild
new file mode 100644
index 000000000000..db19fb8cb3d3
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}