summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-17 12:22:53 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-17 12:23:53 +0800
commit711dbb8cf2131acadb12aa71ff451964d556fe9f (patch)
treece98833251dd86f5bb95191c08101f765d527ef7 /dev-python/pytest-runner/pytest-runner-2.6.1.ebuild
parentwww-client/firefox: Stable for HPPA (bug #556942). (diff)
downloadgentoo-711dbb8cf2131acadb12aa71ff451964d556fe9f.tar.gz
gentoo-711dbb8cf2131acadb12aa71ff451964d556fe9f.tar.bz2
gentoo-711dbb8cf2131acadb12aa71ff451964d556fe9f.zip
dev-python/pytest-runner: add missed dep to DEPEND, bump
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.6.1.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.6.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.6.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.6.1.ebuild
new file mode 100644
index 000000000000..40d1b416d6e1
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests durring installation of setup.py files"
+HOMEPAGE="http://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ # The build by rst2html.py makes non fatal errors building index.rst
+ if use doc; then
+ rst2html.py docs/history.rst > docs/history.html
+ rst2html.py docs/index.rst > docs/index.html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}