summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-30 11:17:00 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-03-30 18:28:06 -0700
commit7301fe6fad4efc2114991bfd73fbb9ca52a53ef1 (patch)
treea6e30a58a9732e2e7ed7d721e50bcf857d65b410 /dev-python/pytest-skip-markers
parentdev-python/pytest-system-statistics: initial import (diff)
downloadgentoo-7301fe6fad4efc2114991bfd73fbb9ca52a53ef1.tar.gz
gentoo-7301fe6fad4efc2114991bfd73fbb9ca52a53ef1.tar.bz2
gentoo-7301fe6fad4efc2114991bfd73fbb9ca52a53ef1.zip
dev-python/pytest-skip-markers: initial import
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest1
-rw-r--r--dev-python/pytest-skip-markers/metadata.xml11
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild53
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
new file mode 100644
index 000000000000..871b412ed285
--- /dev/null
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -0,0 +1 @@
+DIST pytest-skip-markers-1.2.0.tar.gz 79343 BLAKE2B 7f24b454fe19210d9ecadf10317a5a32830d722b64adbaf0fa6fad70a4c0cb598fa93b782a2b0f71bd23c4f91f2007d21383b488d725f61519d064e98ddd48f8 SHA512 76c1d0f0af7f7a56fa95d33bd5cb078792df3f054714d2ca1baa6d861e9404e2ec734a88a0768985388b1226c399ee6b54fe082ef7fcce6fc190fcae6201a416
diff --git a/dev-python/pytest-skip-markers/metadata.xml b/dev-python/pytest-skip-markers/metadata.xml
new file mode 100644
index 000000000000..fe019e56f6a8
--- /dev/null
+++ b/dev-python/pytest-skip-markers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Patrick McLean</name>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-skip-markers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
new file mode 100644
index 000000000000..e4cfe89eb4c5
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION=""
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ dev-python/pytest-shell-utilities[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/setuptools-declarative-requirements[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestskipmarkers/version.py || die
+
+ distutils-r1_python_prepare_all
+}