summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 17:31:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 17:31:13 +0200
commit520963693b8acdf9ccaab8d079cbc542499b1258 (patch)
tree587d8a6837ad79958ad4dce3b4fc0fbf2f454895 /dev-python/pytest-tornado
parentdev-python/asttokens: Enable py3.12 (diff)
downloadgentoo-520963693b8acdf9ccaab8d079cbc542499b1258.tar.gz
gentoo-520963693b8acdf9ccaab8d079cbc542499b1258.tar.bz2
gentoo-520963693b8acdf9ccaab8d079cbc542499b1258.zip
dev-python/pytest-tornado: PEP517, py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tornado')
-rw-r--r--dev-python/pytest-tornado/Manifest1
-rw-r--r--dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-tornado/Manifest b/dev-python/pytest-tornado/Manifest
index cbdd05280393..ed0f90e9a774 100644
--- a/dev-python/pytest-tornado/Manifest
+++ b/dev-python/pytest-tornado/Manifest
@@ -1 +1,2 @@
+DIST pytest-tornado-0.8.1.gh.tar.gz 12616 BLAKE2B 0e9668056c5f6dafd242f311825f830fe1e6428f4c38d030bb0a119f8ae54d511debdb4f839adcfa0881d6ecc79e4889dbed80121cd7a3d4bfb75dd901cb234e SHA512 e655ee9e28461c68b6cc642dbbb203a31154305a603951641e795c605f55970243bb9f7a8858a44bf70faba3d647bea6cf1525f2f9655a968cabbea43beec3d6
DIST pytest-tornado-0.8.1.tar.gz 12616 BLAKE2B 0e9668056c5f6dafd242f311825f830fe1e6428f4c38d030bb0a119f8ae54d511debdb4f839adcfa0881d6ecc79e4889dbed80121cd7a3d4bfb75dd901cb234e SHA512 e655ee9e28461c68b6cc642dbbb203a31154305a603951641e795c605f55970243bb9f7a8858a44bf70faba3d647bea6cf1525f2f9655a968cabbea43beec3d6
diff --git a/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild b/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..9855ec68a82a
--- /dev/null
+++ b/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures and markers to simplify testing of asynchronous tornado applications"
+HOMEPAGE="
+ https://github.com/eugeniy/pytest-tornado/
+ https://pypi.org/project/pytest-tornado/
+"
+SRC_URI="
+ https://github.com/eugeniy/pytest-tornado/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest